CSLA .NET

Vibrant discussion about CSLA .NET and using the framework to build great business applications.

Forum has moved

New location: CSLA .NET forum


CSLA .NET Resources:
  • CSLA .NET forum
  • CSLA .NET home page
  • iis config help

    rated by 0 users
    Answered (Not Verified) This post has 0 verified answers | 1 Reply | 1 Follower

    Not Ranked
    5 Posts
    jpm posted on Wed, Oct 5 2011 6:49 PM

    hi everyone. 

    I have a winforms app running through a wcfhost (app server), setup pretty much like the ProjectTracker example (csla 3.6.3) using csla authentication. 

    The problem I'm having is that unless (on the client - using user accounts -> manage your network passwords)  I store the user credentials of a known user account on the application server against its web address, the client is unable to access the wcfhost service. This network password feature is disabled by default as domain policy.

    My question is how do I (can I ) configure the web server (IIS7 on w2008 svr) to allow anoymous access to the wcfhost service but to process the csla authentication as normal.  I've tried changing various settings on IIS but so far nothing works.

    Any help / advice would be greatly appreciated as I've been banging my head against a wall for some time on this.

    thanks james

    All Replies

    Top 10 Contributor
    4,106 Posts
    Answered (Not Verified) Andy replied on Sun, Oct 9 2011 1:40 PM
    Suggested by Andy

    Is there any reason you can't use Windows authentication? Turn it on as the only option on your WCF site, and then in your client application as soon as you start set the current thread's principal to a new WindowsPrincipal( WindowsIdentity.GetCurrent ).  Also, you'll have to configure Csla to use Windows authentication as well. 

    Page 1 of 1 (2 items) | RSS

    Copyright (c) 2006-2014 Marimer LLC. All rights reserved.
    Email admin@lhotka.net for support.
    Powered by Community Server (Non-Commercial Edition), by Telligent Systems